Problème Chauffe moteur, E46 320i de 98
Postez ici tous vos sujets sur la série 3 (E46) et ses variantes (coupé, berline, touring etc...)

60 messages   •   Page 2 sur 6   •   1, 2, 3, 4, 5, 6
Funkieb
Membre actif
Membre actif
 
Messages: 57
Enregistré le: 03 Mai 2023, 09:24
Localisation: Côte d'armor
Véhicule: BMW (E46) 320i 2l 150cv
Code VIN: JM32319

Re: Problème Chauffe moteur, E46 320i de 98

par Funkieb » 05 Mai 2023, 16:35

Funkieb a écrit:
Dcx a écrit:Attention ce n’est qu’une hypothèse mais vu le kilométrage elle peut être sérieuse mais il y à aussi comme dit plus haut la deuxième sonde sur la culasse et la galère galère pour y accéder bref, pour le moment tu vas essayer via la procédure que je vais te donner d’accéder au menu caché et d’avoir par cette voie la température exacte au tableau de bord de ton liquide de refroidissement. Donc tu met en chauffe et tu fais le test, si les valeurs sont incohérentes (froid,chaud) on va vite le savoir */c1

Procédure déblocage menu caché E46:
Ce menu caché peut être intéressant pour trouver les valeurs de conso instantanée en L/h, la quantité exacte de carburant restant, la température précise du liquide de refroidissement, etc...


:arrow: Informations disponibles :

1.0 Numéro du châssis
1.1 Kilométrage depuis le dernier reset de l'odb (sert à calculer les conso et vitesse moyennes)
1.2 Numéro de série
1.3 Version encodage, diagnostique et bus
1.4 Date de fabrication en semaine / année (Ex : 1002 = 10ème semaine de 2002)
1.5 Version hardware et software
1.6 Statut injection / nombre de cylindres / type moteur
1.7 Indice Bus Can

2.0 Test instrument de bord

3.0 Service intervalle (base de calcul en litres)
3.1 Jours restants jusqu'à la révision du liquide de freins (2 ans)

4.0 Conso instantanée (Ex : 0154 = 15,4L/100km)
4.1 Conso instantanée (Ex : 0011 = 1,1L/h)

5.0 : autonomie consommation (exemple 085=8.5 litres / 100 Km).
5.1 : Autonomie instantanée (nombre de kilomètres pouvant être parcourus avec la quantité de carburant disponible dans le réservoir).

6.0 Quantité restante dans les deux parties du réservoir (Ex : 123321 = 12,3L à gauche et 32,1L à droite)
6.1 Quantité restante dans la totalité du réservoir (Ex : 0652 = 65,2 L)
6.2 Valeur au réservoir, si dernier chiffre à 1 les deux capteurs OK, si 2 erreur capteur, si 3 signal faussé pas d'affichage de valeur

7.0 : Température du liquide de refroidissement moteur en degré Celsius. (Exemple : 0.35= 3.5 °C).
7.1 : Température extérieure (ambiante) en degré Celsius avec une marge d’erreur de 0.5 °C. (exemple : une valeur affichée de 150 signifie que la température extérieure est comprise entre 14.5 °C et 15.5 °C).

7.2 : Régime moteur instantané (en tr/min)
7.3 Vitesse actuelle réelle (en km/h)

8.0 Code hexadécimale des valeurs de 7.0 à 7.3

9.0 Voltage (en Volt)

10.0 Codage pays

11.0 Codage unité

12.0 Non utilisé

13.0 Test du "Gong"

14.0 - 14.4 Mémoire d'erreurs : si 000000 pas d'erreurs sauvegardées

15.0 - 18.0 Non utilisé

19.0 Dé- et verrouillage des Test 3 à 20
L'affichage change au rythme de 3 secondes de I_on auf I_off :
- Déverrouillage : appuyez sur la touche quand I-off apparait
- Verrouillage : appuyez sur la touche quand I-on apparait

20.0 Facteur de correction pour le calcul de la moyenne de conso
Formule : moyenne de conso affichée X 1000 / moyenne conso réelle = facteur
Avec l'appui sur la touche démarre le réglage, les chiffres unitaires de 0 à 9 défilent, quand le bon chiffre apparait appuyer sur la touche
20.1 Programmation des 10aines
20.2 Programmation des 100aines et des milliers
20.3 Validation et affichage des valeurs programmées


:arrow: Comment faire :

Tout se fait avec le bouton reset journalier (celui de gauche).

Pas de risque particulier pour le compteur, l'affichage et les données. Au pire le compteur kilométrique partiel se remettra à zéro si vous rater un truc

1) Moteur à l'arrêt : maintenir le bouton pressé et mettre le contact 1 ou 2.

Ou moteur en marche : rester appuyer sur le bouton jusqu'à ce que menu test apparaisse.

2) Ensuite dès que TEST 1 apparaît, appuyer plusieurs fois sur le bouton jusqu'au menu 19. Sur l'écran apparaît par intermittence I_ON et I_OFF.

3) Appuyer brièvement dès qu'il y a le I_OFF. Cela déverrouille le menu 1 seul fois, il se verrouillera automatiquement si vous ne choisissez pas de TEST.

Attention : vous allez donc de suite basculer sur le menu caché en TEST 0, c'est à ce moment qu'il ne faudra pas perdre de temps, sinon le menu disparaît et il faudra à nouveau aller déverrouiller le test 19.

4) Donc vite appuyer sur le bouton pour passer de test en test 1,2,3,4,5,6....

Exemple : pour passer de test 2.0 à test 2.1, appuyer une fois sur le bouton, etc... pour test 2.2, 2.3, 2.4...... Pour revenir au menu test, genre passer au test 5.0, rester appuyer sur le bouton un laps de temps.

Ensuite appuyer de nouveau par accoups jusqu'au test désiré.


A toi de jouer ²1


Ok, j'essaie cet après-midi.
Mais auquel cas si la température ne correspond pas avec la température du tdb de toute façon la sonde de la culasse n'enclenche pas le moto-ventilateur, c'est celle en sortie du radiateur, non?
A moins que les deux sondes marchent en binôme par mesure de sécurité.
En tous cas c'est intéressant comme manip, je te tiens au courant, merci dcx */c1


J'arrive de la voiture, et, j'ai rien de ce que tu m'as dit *63* , (le ou les ) codes s'arrêtent à 1.07 ou quelque chose du genre.mais pas de menu 19.
Dsl, j'ai fais comme t'as dit mais ça marche pas.

Funkieb
Membre actif
Membre actif
 
Messages: 57
Enregistré le: 03 Mai 2023, 09:24
Localisation: Côte d'armor
Véhicule: BMW (E46) 320i 2l 150cv
Code VIN: JM32319

Re: Problème Chauffe moteur, E46 320i de 98

par Funkieb » 05 Mai 2023, 17:58

Funkieb a écrit:
Dcx a écrit:Attention ce n’est qu’une hypothèse mais vu le kilométrage elle peut être sérieuse mais il y à aussi comme dit plus haut la deuxième sonde sur la culasse et la galère galère pour y accéder bref, pour le moment tu vas essayer via la procédure que je vais te donner d’accéder au menu caché et d’avoir par cette voie la température exacte au tableau de bord de ton liquide de refroidissement. Donc tu met en chauffe et tu fais le test, si les valeurs sont incohérentes (froid,chaud) on va vite le savoir */c1

Procédure déblocage menu caché E46:
Ce menu caché peut être intéressant pour trouver les valeurs de conso instantanée en L/h, la quantité exacte de carburant restant, la température précise du liquide de refroidissement, etc...


:arrow: Informations disponibles :

1.0 Numéro du châssis
1.1 Kilométrage depuis le dernier reset de l'odb (sert à calculer les conso et vitesse moyennes)
1.2 Numéro de série
1.3 Version encodage, diagnostique et bus
1.4 Date de fabrication en semaine / année (Ex : 1002 = 10ème semaine de 2002)
1.5 Version hardware et software
1.6 Statut injection / nombre de cylindres / type moteur
1.7 Indice Bus Can

2.0 Test instrument de bord

3.0 Service intervalle (base de calcul en litres)
3.1 Jours restants jusqu'à la révision du liquide de freins (2 ans)

4.0 Conso instantanée (Ex : 0154 = 15,4L/100km)
4.1 Conso instantanée (Ex : 0011 = 1,1L/h)





5.0 : autonomie consommation (exemple 085=8.5 litres / 100 Km).
5.1 : Autonomie instantanée (nombre de kilomètres pouvant être parcourus avec la quantité de carburant disponible dans le réservoir).

6.0 Quantité restante dans les deux parties du réservoir (Ex : 123321 = 12,3L à gauche et 32,1L à droite)
6.1 Quantité restante dans la totalité du réservoir (Ex : 0652 = 65,2 L)
6.2 Valeur au réservoir, si dernier chiffre à 1 les deux capteurs OK, si 2 erreur capteur, si 3 signal faussé pas d'affichage de valeur

7.0 : Température du liquide de refroidissement moteur en degré Celsius. (Exemple : 0.35= 3.5 °C).
7.1 : Température extérieure (ambiante) en degré Celsius avec une marge d’erreur de 0.5 °C. (exemple : une valeur affichée de 150 signifie que la température extérieure est comprise entre 14.5 °C et 15.5 °C).

7.2 : Régime moteur instantané (en tr/min)
7.3 Vitesse actuelle réelle (en km/h)

8.0 Code hexadécimale des valeurs de 7.0 à 7.3

9.0 Voltage (en Volt)

10.0 Codage pays

11.0 Codage unité

12.0 Non utilisé

13.0 Test du "Gong"

14.0 - 14.4 Mémoire d'erreurs : si 000000 pas d'erreurs sauvegardées

15.0 - 18.0 Non utilisé

19.0 Dé- et verrouillage des Test 3 à 20
L'affichage change au rythme de 3 secondes de I_on auf I_off :
- Déverrouillage : appuyez sur la touche quand I-off apparait
- Verrouillage : appuyez sur la touche quand I-on apparait

20.0 Facteur de correction pour le calcul de la moyenne de conso
Formule : moyenne de conso affichée X 1000 / moyenne conso réelle = facteur
Avec l'appui sur la touche démarre le réglage, les chiffres unitaires de 0 à 9 défilent, quand le bon chiffre apparait appuyer sur la touche
20.1 Programmation des 10aines
20.2 Programmation des 100aines et des milliers
20.3 Validation et affichage des valeurs programmées


:arrow: Comment faire :

Tout se fait avec le bouton reset journalier (celui de gauche).

Pas de risque particulier pour le compteur, l'affichage et les données. Au pire le compteur kilométrique partiel se remettra à zéro si vous rater un truc

1) Moteur à l'arrêt : maintenir le bouton pressé et mettre le contact 1 ou 2.

Ou moteur en marche : rester appuyer sur le bouton jusqu'à ce que menu test apparaisse.

2) Ensuite dès que TEST 1 apparaît, appuyer plusieurs fois sur le bouton jusqu'au menu 19. Sur l'écran apparaît par intermittence I_ON et I_OFF.

3) Appuyer brièvement dès qu'il y a le I_OFF. Cela déverrouille le menu 1 seul fois, il se verrouillera automatiquement si vous ne choisissez pas de TEST.

Attention : vous allez donc de suite basculer sur le menu caché en TEST 0, c'est à ce moment qu'il ne faudra pas perdre de temps, sinon le menu disparaît et il faudra à nouveau aller déverrouiller le test 19.

4) Donc vite appuyer sur le bouton pour passer de test en test 1,2,3,4,5,6....

Exemple : pour passer de test 2.0 à test 2.1, appuyer une fois sur le bouton, etc... pour test 2.2, 2.3, 2.4...... Pour revenir au menu test, genre passer au test 5.0, rester appuyer sur le bouton un laps de temps.

Ensuite appuyer de nouveau par accoups jusqu'au test désiré.


A toi de jouer ²1


Ok, j'essaie cet après-midi.
Mais auquel cas si la température ne correspond pas avec la température du tdb de toute façon la sonde de la culasse n'enclenche pas le moto-ventilateur, c'est celle en sortie du radiateur, non?
A moins que les deux sondes marchent en binôme par mesure de sécurité.
En tous cas c'est intéressant comme manip, je te tiens au courant, merci dcx */c1


Ça marche pas,! J'ai fait comme tu m'as dis, et rien. Ça veut dire quoi ? Mon odb est HS?

Avatar de l’utilisateur
Dcx
Administrateur du site
Administrateur du site
 
Messages: 9700
Enregistré le: 15 Juil 2007, 12:49
Localisation: RP
Véhicule: Bmw (E90) 330d pack sport M
Code VIN:

Re: Problème Chauffe moteur, E46 320i de 98

par Dcx » 05 Mai 2023, 21:30

Tu attends bien une dizaine de secondes quand tu appuie pour 46*

Je te remet la manip, à mon avis tu as du loupé un truc…

Tu démarre le moteur. Maintient ensuite le bouton de remise à zéro du compteur kilométrique journalier enfoncé jusqu’à l’apparition du menu « Test » sur l’afficheur du combiné d’instruments. Cela prend environ 10 secondes pour voir ce menu apparaitre à la place du kilométrage. Il est également possible de commencer la manipulation lorsque le moteur est arrêté. Pour ce faire, mets la clé de contact sur la position « 0 ». Maintiens le bouton de remise à zéro enfoncé et tournez la clé de contact en position « 1 » (borne R, position autoradio) ou position 2 (avant la position de démarrage). Jusque là ça va?

Lorsque le menu « Test » apparait sur l’afficheur du combiné d’instruments, relâches le bouton de remise à zéro. Appuie ensuite rapidement sur le bouton (sans l’enfoncer) pour faire défiler les menus de tests. Lorsque tu arrives au menu « Test 19 », relâches le bouton. Au bout de 2 secondes, tu vas voir deux messages qui vont apparaitre par intermittence : « L_On » (Lock On) et « L_Off » (Lock Off). Dès que le message « L_Off » apparaisse sur l’écran, appuie brièvement sur le bouton de remise à zéro. Cela aura pour effet de déverrouiller les menus cachés ok ²1

Ensuite tu reprend comme je te l’ai décrit plus haut pour arriver au menu recherché le 7 il me semble, je te met une video rapide pour t’aider à te rendre compte …Cette procédure fonctionne depuis plus de dix ans sur E46



Bonne soirée **2

Funkieb
Membre actif
Membre actif
 
Messages: 57
Enregistré le: 03 Mai 2023, 09:24
Localisation: Côte d'armor
Véhicule: BMW (E46) 320i 2l 150cv
Code VIN: JM32319

Re: Problème Chauffe moteur, E46 320i de 98

par Funkieb » 06 Mai 2023, 05:00

Ouais bon, ok, j'ai dû lire ta réponse en travers comme une andouille ou vouloir aller trop vite, */7 je recommence cet après-midi.
Merci pour ton soutien et la vidéo, c'est super sympa de ta part !! ²1

Funkieb
Membre actif
Membre actif
 
Messages: 57
Enregistré le: 03 Mai 2023, 09:24
Localisation: Côte d'armor
Véhicule: BMW (E46) 320i 2l 150cv
Code VIN: JM32319

Re: Problème Chauffe moteur, E46 320i de 98

par Funkieb » 08 Mai 2023, 16:30

Bon voilà cette fois-ci j'ai pas grillé les étapes, donc la voiture est montée très doucement en température puisqu'elle était au ralenti et voici ce que j'ai obtenu...
Entre le moment où je l'ai démarrée (vers 15h10 ou 15h15) jusqu'à 15h 40, elle est montée à 102°c sans déclencher le moto-ventilateur ni même le visco-coupleur.
Pour finir la durite en sortie de radiateur qui héberge la sonde de température était froide et le radiateur était chaud en haut et froid en bas.
Ne serait-ce pas le thermostat qui finalement serait HS, lequel j'avais pensé être encore en bon état ??

Cordialement

Troatrente
Membre actif
Membre actif
 
Messages: 117
Enregistré le: 13 Jan 2023, 18:18
Véhicule: BMW E46 330d
Code VIN: Pa26829

Re: Problème Chauffe moteur, E46 320i de 98

par Troatrente » 10 Mai 2023, 03:11

Bonjour,

Si le radiateur est chaud en haut et froid en bas c'est qu'on circule mal.

Du coup le visco n'enclenche pas car il ne monte pas assez en température vu que l'air qui l'irrigue n'est pas chauffé par le radiateur. A ce sujet j'ai déjà entendu parler de viscos neufs HS, tu as mis de la monte d'origine quand tu l'as remplacé ?

Soit l'aquastat est HS, soit la pompe (mais il me semble avoir lu que tu avais remplacé les deux ?)
Tu as du chauffage dans l'habitacle ?) Regardes si chauffage et ventilation à fond la température moteur redescend un peu (en refaisant la manip au tableau de bord pour avoir des valeurs précises) si la temp descend c'est que la pompe fonctionne, normalement le chauffage habitacle est en prise directe, sans passer par l'aquastat.

Soit tu as une grosse bulle d'air qui empêche la circulation.
Refaire la procédure de purge ne coûte pas grand chose, la procédure n'est pas compliquée mais doit être respectée scrupuleusement, il y a plein de vidéos tutos sur YouTube.

Certains aquastats neufs sont mal calibrés, là encore tu as mis de la monte d'origine ? Si tu as un thermostat électronique tu peux vérifier à quelle température il s'ouvre en le plongeant dans une casserole d'eau sur ta plaque de cuisson. S'il ne commence à s'ouvrir qu'à 102 degrés tu auras ta réponse.

Si tout ça ne résout rien il faut chercher un "bouchon" dans le circuit...

Funkieb
Membre actif
Membre actif
 
Messages: 57
Enregistré le: 03 Mai 2023, 09:24
Localisation: Côte d'armor
Véhicule: BMW (E46) 320i 2l 150cv
Code VIN: JM32319

Re: Problème Chauffe moteur, E46 320i de 98

par Funkieb » 10 Mai 2023, 09:48

Troatrente a écrit:Bonjour,

Si le radiateur est chaud en haut et froid en bas c'est qu'on circule mal.

Du coup le visco n'enclenche pas car il ne monte pas assez en température vu que l'air qui l'irrigue n'est pas chauffé par le radiateur. A ce sujet j'ai déjà entendu parler de viscos neufs HS, tu as mis de la monte d'origine quand tu l'as remplacé ?

Soit l'aquastat est HS, soit la pompe (mais il me semble avoir lu que tu avais remplacé les deux ?)
Tu as du chauffage dans l'habitacle ?) Regardes si chauffage et ventilation à fond la température moteur redescend un peu (en refaisant la manip au tableau de bord pour avoir des valeurs précises) si la temp descend c'est que la pompe fonctionne, normalement le chauffage habitacle est en prise directe, sans passer par l'aquastat.

Soit tu as une grosse bulle d'air qui empêche la circulation.
Refaire la procédure de purge ne coûte pas grand chose, la procédure n'est pas compliquée mais doit être respectée scrupuleusement, il y a plein de vidéos tutos sur YouTube.

Certains aquastats neufs sont mal calibrés, là encore tu as mis de la monte d'origine ? Si tu as un thermostat électronique tu peux vérifier à quelle température il s'ouvre en le plongeant dans une casserole d'eau sur ta plaque de cuisson. S'il ne commence à s'ouvrir qu'à 102 degrés tu auras ta réponse.

Si tout ça ne résout rien il faut chercher un "bouchon" dans le circuit...


Bonjour,
D'abord merci de te pencher sur le sujet une aide supplémentaire est toujours la bienvenue.
Pour le visco voire toutes les pièces que j'achète viennent de sites internet dont la compatibilité est de 100% et selon leur fonction j'évite les premiers prix aux marques peu connues et je n'ai jamais eu de problème.
En ce qui concerne le thermostat et la pompe je ne les ai pas changé. Dans l'immédiat mes pensées se tournent vers le thermostat et non vers la pompe car effectivement j'ai du chauffage dans l'habitacle et le jet de pompe sous le bouchon du vase d'expansion, mais à surveiller comme le préconise dcx.
Pour la purge j'ai vérifié plusieurs fois le niveau et fais l'appoint donc RAS.
J'ai bien envie de démonter le thermostat et de le tester au moins j'en aurai le cœur net. Quitte à le remplacer même si il fonctionne encore de toute façon il doit avoir pas mal d'années. J'en profiterais par la même occasion de vérifier si il y a un bouchon dans le radiateur c'est pas non plus impossible quitte à vidanger le circuit autant s'en assurer.
Cordialement

Troatrente
Membre actif
Membre actif
 
Messages: 117
Enregistré le: 13 Jan 2023, 18:18
Véhicule: BMW E46 330d
Code VIN: Pa26829

Re: Problème Chauffe moteur, E46 320i de 98

par Troatrente » 10 Mai 2023, 18:21

Je viens de regarder une vidéo et apparemment la circulation du chauffage habitacle est assurée par une pompe électrique ²2

A confirmer, mais si c'est vrai on a plus de certitude sur le bon fonctionnement de ta pompe à eau. Le jet sous le bouchon indique qu'on circule mais pas forcément que le débit est suffisant...

Mais d'après tes symptômes je penche plutôt vers une défaillance de l'aquastat.

Funkieb
Membre actif
Membre actif
 
Messages: 57
Enregistré le: 03 Mai 2023, 09:24
Localisation: Côte d'armor
Véhicule: BMW (E46) 320i 2l 150cv
Code VIN: JM32319

Re: Problème Chauffe moteur, E46 320i de 98

par Funkieb » 10 Mai 2023, 18:52

Troatrente a écrit:Je viens de regarder une vidéo et apparemment la circulation du chauffage habitacle est assurée par une pompe électrique ²2

A confirmer, mais si c'est vrai on a plus de certitude sur le bon fonctionnement de ta pompe à eau. Le jet sous le bouchon indique qu'on circule mais pas forcément que le débit est suffisant...

Mais d'après tes symptômes je penche plutôt vers une défaillance de l'aquastat.


Ah!, j'ai pas à ma connaissance qu'il y aurait une pompe spécifique pour le circuit de chauffage après tout pourquoi pas, je sais qu'il y a une electrovanne par contre.
Pour la pompe j'ai quand-même un sérieux doute, en admettant qu'elle ai ne serait-ce qu'un petit débit et que le thermostat fonctionne correctement dans ce cas il n'y a aucune raison pour que le bas du radiateur reste froid et que les deux ventilos (moto-ventilateur et visco) ne s'enclenchent pas.
Au fait quand tu parles d'aquastat c'est bien du thermostat que tu fais allusion ??
Cdlt

Troatrente
Membre actif
Membre actif
 
Messages: 117
Enregistré le: 13 Jan 2023, 18:18
Véhicule: BMW E46 330d
Code VIN: Pa26829

Re: Problème Chauffe moteur, E46 320i de 98

par Troatrente » 10 Mai 2023, 19:48

Je parle de l'aquastat ou thermostat fixé sur le bloc moteur et sur lequel sont emmanchées les durites de refroidissement, le 4 sur le schéma ci-dessous :

Image

Tant que le moteur n'a pas atteint sa température de service le liquide de refroidissement ne va pas jusqu'au radiateur. Le but est de ne pas retarder la montée en température du bloc.
Une fois atteint environ 90 degrés environ il s'ouvre et le fluide chaud part se refroidir dans le radiateur. A ma connaissance le thermostat fixé au radiateur n'est qu'une sonde qui envoie l'info de température au calculateur.
Le gros ventilateur s'enclenche lui aussi mécaniquement quand le viscocoupleur (gros disque à ailettes fixé sur les pales) se dilate sous la chaleur (il embraye sur l'axe du vilebrequin si je ne dis pas de bêtises). Donc si l'aquastat est grippé en position fermée, ton radiateur n'est pas irrigué par le liquide de refroidissement, donc il ne chauffe pas, donc il ne chauffe pas non plus l'air qui vient "arroser" le viscocoupleur, donc ce dernier n'embraye pas et ton ventilateur ne tourne pas ou presque pas.

Si tu as aussi un ventilateur électrique sur ton radiateur ça peut être pour la clim ou en cas de trop haute température mais là j'avoue ne pas être sûr de mon coup, je n'ai eu que des diesels BMW, ce qui est sensiblement différent.

Si la durite située entre l'aquastat et le radiateur n'est pas chaude c'est que le liquide de refroidissement ne passe pas par là, donc soit pompe HS (ce qui ne semble pas être le cas) soit ton aquastat reste collé, soit tu as un bouchon dans le circuit (calcaire, rouille, mayonnaise si joint de culasse HS par exemple)

  Précédente   Suivante
60 messages   •   Page 2 sur 6   •   1, 2, 3, 4, 5, 6

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 6 invités

Nous sommes le 01 Mar 2024, 03:09