E46, probleme de diag impossible
Postez ici tous vos sujets sur la série 3 (E46) et ses variantes (coupé, berline, touring etc...)

50 messages   •   Page 5 sur 5   •   1, 2, 3, 4, 5
Avatar de l’utilisateur
henrique75
Membre Assidu
Membre Assidu
 
Messages: 351
Enregistré le: 08 Juil 2011, 10:53
Véhicule: BMW e46 Cabrio pack M2
Code VIN:

Re: E46, probleme de diag impossible

par henrique75 » 30 Mai 2013, 16:40

Je vous ai donné au début du Topic des contrôles à effectuer, ont-ils été faits ?
Le problème ne viens ni du câble (sinon le diag passerai normalement avec le DIS) ni d’un module HS (sinon tu pourrais dialoguer avec les autres modules, et le véhicule ne démarrai pas si c’était le DME).
Les interfaces de communications prennent leur alimentation directement sur la prise diag (DLC), si pas d’alim : pas de diag !
Commence par contrôler les alimentations de la prise diag.

julgro
Nouveau Membre
Nouveau Membre
 
Messages: 18
Enregistré le: 28 Mai 2013, 19:59
Véhicule: Bmw (E60) 525d
Code VIN:

Re: E46, probleme de diag impossible

par julgro » 30 Mai 2013, 21:17

henrique75 a écrit:DLC = Diagnostic Link Connector c'est ta prise obd si tu préfere (excuse moi je travaille chez les ricains **1 )

tester toute les voies ne sert pas forcement à grand chose, voici l'emplacement des voies :
Mais je ne suis pas spécialiste bmw, ceci est un schéma de prise obd standard (ford, lincoln, continental, mercury, jaguar, land rover...)

pin 1 : + après contact
pin 2 : Bus SCP (+)
pin 3 : Medium Speed (ms can)
pin 4 : Masse
pin 5 : Signal de masse
pin 6 : CAN-bus (+)
pin 7 : ISO 9141
pin 8 : Libre
pin 9 : + après contact
pin 10 : Bus SCP (-)
pin 11 : MS can (+)
pin 12: libre
pin 13 : Signal de programmation module
pin 14 : Bus CAN (-)
pin 15 : ISO 9141 (-)
pin 16 : + permanent (30)

Bien sur ca vari en fonction du protocol de comunication, je sai que chez bmw le ms can et hs can peut etre different. D'ailleur la pin 8 est souvent utilisé chez BMW.


Je suis censé avoir quoi en sortie MS can, BUS can... Les signaux doivent être pris avec quel genre d’appareil de mesure? Car j'hésite à mesurer en ayant peur de mal m'y prendre. Je mesure uniquement les pins 1,9 et 16 après contact alors?
En tous les cas j'ai bien saisi ton résonnement et il est évident que c'est un problème d'alim mineur.
Hier j'ai branché un module de ELM 327 et j'ai réussi à dialoguer avec le véhicule (je précise que mon câble fonctionne sur une autre auto).

Avatar de l’utilisateur
henrique75
Membre Assidu
Membre Assidu
 
Messages: 351
Enregistré le: 08 Juil 2011, 10:53
Véhicule: BMW e46 Cabrio pack M2
Code VIN:

Re: E46, probleme de diag impossible

par henrique75 » 31 Mai 2013, 11:04

Pour les contrôles de réseaux en général c'est :

HS-CAN Broche 6 High = 2.6 volts
Broche 14 Low = 2.4 volts

MS-CAN Broche 3 High = 2.6 volts
Broche 11 Low = 2.4 volts

Résistances de terminaison pour chaque réseau : 60 ohms
Cette résistance est due à la bonne connexion des modules de terminaisons (ils ont chacun une valeur respective de 120 Ohms.)
Si lors du contrôle vous relevez une valeur de 120 Ohms cela indique qu’un des modules de terminaison n’est pas connecté au réseau.


Avant de partir sur des contrôles de réseaux, contrôlez déja les masses et alim de la prise diag.

Masses en Pin 4 et 5

Alimentation batterie en Pin 16.

julgro
Nouveau Membre
Nouveau Membre
 
Messages: 18
Enregistré le: 28 Mai 2013, 19:59
Véhicule: Bmw (E60) 525d
Code VIN:

Re: E46, probleme de diag impossible

par julgro » 31 Mai 2013, 15:33

henrique75 a écrit:Pour les contrôles de réseaux en général c'est :

HS-CAN Broche 6 High = 2.6 volts
Broche 14 Low = 2.4 volts

MS-CAN Broche 3 High = 2.6 volts
Broche 11 Low = 2.4 volts

Résistances de terminaison pour chaque réseau : 60 ohms
Cette résistance est due à la bonne connexion des modules de terminaisons (ils ont chacun une valeur respective de 120 Ohms.)
Si lors du contrôle vous relevez une valeur de 120 Ohms cela indique qu’un des modules de terminaison n’est pas connecté au réseau.


Avant de partir sur des contrôles de réseaux, contrôlez déja les masses et alim de la prise diag.

Masses en Pin 4 et 5

Alimentation batterie en Pin 16.


L'alimentation permanente Pin 16 c'était bon pour ma part et pour les masses aussi.

Pour le contrôle des réseaux je me place en borne 6 ou 14 et à une masse de la prise? Cela ne présente aucun risque?

Pour le contrôle de la résistance je me place entre le les bornes high et low de chaque réseaux et je doit avoir 60 ohms?

Désolé de faire le boulet mais je veux être certain de pas faire un bétise...

Avatar de l’utilisateur
henrique75
Membre Assidu
Membre Assidu
 
Messages: 351
Enregistré le: 08 Juil 2011, 10:53
Véhicule: BMW e46 Cabrio pack M2
Code VIN:

Re: E46, probleme de diag impossible

par henrique75 » 31 Mai 2013, 16:13

Attention ! Autant les masses et alim sont communes à toutes les marques, autant les réseaux multiplexé dépende de chaque constructeur !
En générale chez 80 % des constructeurs, sur les véhicules récent, les pin 3 et 11 ainsi que 6 et 14 correspondes au réseau multiplexé Can, maintenant vérifie quand même sur un schéma que ce soit pareil sur une e46. Je sais que BMW utilise (ou utilisait) en plus du réseau Can un réseau ISO 9141 de mémoire qui était situé en pin 7 et 15, le Can restai en 6 et 14.

julgro
Nouveau Membre
Nouveau Membre
 
Messages: 18
Enregistré le: 28 Mai 2013, 19:59
Véhicule: Bmw (E60) 525d
Code VIN:

Re: E46, probleme de diag impossible

par julgro » 31 Mai 2013, 20:05

henrique75 a écrit:Attention ! Autant les masses et alim sont communes à toutes les marques, autant les réseaux multiplexé dépende de chaque constructeur !
En générale chez 80 % des constructeurs, sur les véhicules récent, les pin 3 et 11 ainsi que 6 et 14 correspondes au réseau multiplexé Can, maintenant vérifie quand même sur un schéma que ce soit pareil sur une e46. Je sais que BMW utilise (ou utilisait) en plus du réseau Can un réseau ISO 9141 de mémoire qui était situé en pin 7 et 15, le Can restai en 6 et 14.


Ok merci de tes conseils, je vais regarder tout ça des que j'ai un peu de temps. Je mettrai mon compte rendu ici :trinque:

Rodage
Membre Assidu
Membre Assidu
 
Messages: 304
Enregistré le: 05 Sep 2010, 20:48
Véhicule: Bmw 330d ph2
Code VIN:

Re: E46, probleme de diag impossible

par Rodage » 03 Juin 2013, 13:49

Salut a tous !

Oui j'ai le meme probleme que toi ! Avec Carsoft, toutes les diodes s'allument sauf une, qui s'allume puis s'etaint de maniere intempestive (genre faux contact) ...je n'arrive a rien ! L'lec n'etant point mon fort...

Henrique, merci pour tes conseils, j'avais fais les tests d'alim et masse, tout est ok chez moi. en revanche je n'ai pas fait les tests de resistance... ne sachant pas utiliser un multimetre correctement !! **1

Je vais re tenter... Merci de me donner la force et le courage ! **2 *11* *15*

julgro
Nouveau Membre
Nouveau Membre
 
Messages: 18
Enregistré le: 28 Mai 2013, 19:59
Véhicule: Bmw (E60) 525d
Code VIN:

Re: E46, probleme de diag impossible

par julgro » 26 Juil 2013, 20:53

J'ai enfin résolu mon problème ! *65*

Alors le soucis que j'ai eu j'ai utilisé comme j'ai dit plus haut un émulateur d'ICOM en "farfouillant" j'ai changé la vitesse du bus CAN.

Pour tout remettre normal j'ai utilisé K+DCAN utility 2.0 -> http://osefactory.com/tools/k+dcan/ (dcan_tools.rar)

Ensuite j'ai lancé le logiciel, connecté mon câble au PC et à la prise OBD de l'auto, la lumière du câble s'allume, j'ai ensuite sélectionné 500Kbit/s D-CAN & PT-CAN, la lumière s'éteint (done dans la log du logiciel).

Test avec INPA et tout est ok pour moi, je suis au ange *009

J'espère t'avoir mis sur une piste.

olivierg
Nouveau Membre
Nouveau Membre
 
Messages: 4
Enregistré le: 04 Sep 2015, 15:05
Véhicule: BMW E46 330cia cabriolet M Sport
Code VIN: EH35439

Re: E46, probleme de diag impossible

par olivierg » 22 Nov 2015, 18:31

Bonjour à tous,
Je fais remonter ce vieux sujet pour savoir si les forumeurs concernés ont pu régler ce problème, et si oui, comment ils l'ont fait.
J'ai également ce problème sur ma 330ci de 2002 made in Germany. Tout me semble bon au niveau de la connectique et des tensions, sauf que je n'ai pas plus de 0.6V dans la fiche n°8 de la prise OBD (qui correspond à la ligne TXD du bus K), alors que j'ai 10V dans la fiche n°7 (qui correspond à la ligne TXD2 du bus K).
Merci :-)
Olivier

Bengoup
Nouveau Membre
Nouveau Membre
 
Messages: 1
Enregistré le: 28 Fév 2016, 20:29
Véhicule: Bmw (E46) 330i
Code VIN: Pd80997

Re: E46, probleme de diag impossible

par Bengoup » 25 Sep 2017, 21:53

Bonsoir,

Déterrage de post également pour savoir si qqu'un avait trouvé la solution.
Je suis également dans le même cas sur ma 330I de 2003. Ce qui me rassure c'est qu’apparemment mon pb n'est pas un cas unique...
Merci.

Benoît.

  Précédente
50 messages   •   Page 5 sur 5   •   1, 2, 3, 4, 5

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités

Nous sommes le 17 Déc 2017, 18:54